家庭宽带IPV6使用方式,终端SLAAC,DHCPV6自动配置

使用运营商分配的ipv6地址分几种情况
  1 运营商只给一段 ipv6(一般不会)
  2 运营商分配一段供互联使用ipv6,另外给一段PD前缀
对于第一种方式
  没有更好的办法,地址分配服务端在运营商设备,如果要使用,只能把插路由器wan口的线插lan口上
第二种方式
  首先要明确两个概念,无状态自动分配,有状态自动分配
  前者就是我们日常所说的SLAAC,后者就是DHCPV6
  运营商分配给拨号设备的地址不能继续由路由器往下进行二次分配,另外给的一段前缀地址(/56或/60)可以由路由器进行分配
我们只讨论第二种的实现方式
架构
  运营商路由器接口配置ipv6地址,开启RA功能,供家宽拨号设备通过SLAAC配置IPV6地址和网关
  运营商路由器配置DHCPV6 PD地址池,作为PD服务端,同时数据做给家宽拨号设备
  家宽拨号设备配置DHCPV6 PD客户端,向运营商请求地址池,LAN口开启RA功能,或配置DHCPV6地址池,供家庭终端自动获取IPV6地址与网关

分享下我的个人配置

  我使用华为AR路由器做为拨号设备,TP-LINK路由器做AP,拓扑如下

路由器配置如下

#配置内网DHCPV4 地址池
ip pool dark
 gateway-list 172.18.0.1 
 network 172.18.0.0 mask 255.255.255.0 
 dns-list 114.114.114.114 8.8.8.8 

#配置拨号端口

interface Dialer1
 link-protocol ppp
 ppp chap user 037xxxx
 ppp chap password simple xxxx

 ipv6 enable
 tcp adjust-mss 1200
 ip address ppp-negotiate
 dialer user 037xxxx
 dialer bundle 1

#配置WAN口ipv6地址,SLAAC自动配置
 ipv6 address auto link-local
 ipv6 address auto global default
 nat outbound 2001
 dhcpv6 client pd dark



#配置lan口
interface GigabitEthernet0/0/1
 undo portswitch
 ipv6 enable
 ip address 172.18.0.1 255.255.255.0
#使用PD服务器提供的前缀自动配置ip
 ipv6 address dark ::1/64
 ipv6 address auto link-local
#开启RA报文通告功能
 undo ipv6 nd ra halt
 dhcp select global


interface GigabitEthernet0/0/4
 pppoe-client dial-bundle-number 1

配置完成后查看路由器接口IPV6地址

查看路由表

查看终端获取到的ipv6地址

查看路由器上ipv6邻居关系表

ipv6test网站测试

网站ping终端ipv6地址测试

以上,完成了家宽IPV6前缀的下发与地址自动配置

当然带图形界面的路由器设置起来更为简单,以TP-LINK企业级路由器为例

在WAN口开启前缀授权,复用IPV4拨号链路,设置后可以看到PD前缀

LAN口绑定所授权的WAN口,也可以选择使用WAN口获取到的PD前缀进行DHCPV6 配置

Leave a Reply

Your email address will not be published. Required fields are marked *

X